Administration 03.2019 - Update - KnowledgeBase

Hallo zusammen,


endlich...
Endlich habe ich eine einigermaßen vernünftige Version einer Teilübersetzung für das Frontend von Xenforo bekommen. Leider wird dieses sehr perfomante Forensystem in England entwickelt und hat für sich nur den Anspruch in der Weltsprache verfügbar zu sein. Das führt dazu, dass in der letzten Zeit ziemlich viele halbgare Übersetzungen auf den Markt geworfen wurden, wofür auch noch Geld verlangt wurde... Da ich auf die Übersetzung eines sehr! sehr guten Übersetzers gewartet habe, hat es sich lange hingezogen - und dieser nimmt sich jetzt NOCH mehr Zeit. Er ist ein Perfektionist und schießt meines Erachtens da auch über das Ziel hinaus. Aber ändern kann ich es nicht.

Kommen wir zum aktuellen Update.

Die Forensoftware ist von der Version 1.5.21 auf die Version 2.1 gehoben worden. Versierte Nutzer erkennen einen großen und einen Teilsprung.

Der Sprung von 1.5.x auf 2.0 brachte unter anderem folgendes mit sich:
Stark verbesserter mobilfreundlicher Stil

Der neue XenForo 2 Stil ist das erste, was Sie in XF2 bemerken werden. Der gesamte Stil wurde mit einem frischen, neuen Erscheinungsbild, aber auch mit mobilem Surfen im Vordergrund des Designs neu gestaltet. Wenn das Ansichtsfenster verkleinert wird, verkleinert sich der Inhalt auf der Seite, verschiebt sich und reorganisiert sich automatisch, um das Surferlebnis für kleine Displays zu optimieren.
Ein Sticky-Header wird beim Scrollen des Fensters automatisch aktiviert, so dass die wichtigsten Navigationssteuerungen jederzeit verfügbar bleiben.

Emoji-Unterstützung* ✍
Alle Textinhalte in XenForo 2 unterstützen nun Emoji, vom Nachrichtentext bis zum Forentitel.

Retina Avatar und Smilie Unterstützung
Avatare und Smilies unterstützen jetzt hochauflösende Bilder, was ein gestochen scharfes, hochauflösendes Display ermöglicht, das dem Text auf Displays mit 2x Grafikauflösung, wie beispielsweise Apples Retina-Displays, entspricht.

Navigationsmanager
Sowohl die öffentlich zugänglichen Systeme als auch das Admin-Control-Panel verfügen nun über vollständig anpassbare Navigationssysteme, so dass der Inhalt der Navigationsleisten und Seitennavigationsblöcke vollständig vom Seitenadministrator gesteuert werden kann, ohne dass auf Vorlagenänderungen zurückgegriffen werden muss.

Widgets
Widgets sind kleine Blöcke von Inhalten, die eine Vielzahl von Aufgaben erfüllen können, wie z.B. die Anzeige einer Liste von Mitgliedern online, oder die Anzeige der neuesten Beiträge usw. Widgets können über eine einfache Benutzeroberfläche auf verschiedenen Seiten innerhalb der öffentlich zugänglichen Seite von XenForo platziert werden, so dass Sie umfangreiche Content-Discovery-Systeme in fast jedem Bereich des öffentlichen Forums integrieren können.

Verbesserte Nachrichtenbearbeitung
Anstatt ein Overlay zu öffnen, erfolgt die Bearbeitung von Nachrichten nun vollständig vor Ort, wobei der Inhalt der Nachrichten durch einen vollwertigen Nachrichteneditor ersetzt wird, der die gesamte Bandbreite an Bearbeitungs- und Buchungsvorgängen einschließlich der Anlagenverwaltung ermöglicht.

Warnmeldungen in Favicon
Wenn neue Benachrichtigungen oder ungelesene Gesprächsmeldungen verfügbar sind, wird dem Standortsymbol (in der Browser-Titelzeile angezeigt) ein Badge hinzugefügt, das anzeigt, dass auf die Anzeige wartende Elemente vorhanden sind.

....
Weiteres könnt ihr hier nachlesen: XF 2.0 - What's new in XenForo 2.0


Version 2.1
Mit dem dann erfolgten Sprung auf die Version 2.1 kam noch einmal folgendes hinzu:

Heute freuen wir uns, Ihnen mitteilen zu können, dass XenForo 2.1.0 seine Vorabversionsphase abgeschlossen hat und nun unsere primär unterstützte XenForo-Version ist. Diese Version erweitert XenForo um eine Reihe wichtiger Funktionen. Zu den wichtigsten Funktionen gehören:
  • Native Push-Benachrichtigungen auf unterstützten Geräten/Browsern
  • Verwaltung der Editor-Schaltflächen
  • Verbesserte Editor-Integration und erweiterte BB-Codeoptionssyntax
  • Abschriftenunterstützung
  • Tische
  • Reaktionen
  • URL entfaltet sich
  • Emoji-Verbesserungen, einschließlich eines verbesserten Smilie-Menüs mit einfachem Emoji-Zugang.
  • Video-Uploads
  • Verbesserungen bei der Genehmigungswarteschlange
  • Verbesserungen der Gastleistung, einschließlich des Zwischenspeicherns von Gastseiten.
  • Lesezeichen für Inhalte und Freigabe von Inhalten
  • Eine voll ausgestattete REST-API
  • XenForo-Upgrades und einfachere Add-On-Installation mit einem Klick
  • BB-Code und Rich Text Bearbeitung für Profilbeiträge und Kommentare
Altbekanntes wie das Portal, die Galerie, die KnowledgeBase wird alles wieder kommen.
Leider bringt die alte Software (da Drittanbieter genutzt wurden) keine Möglichkeit mit, alles einfach zu importieren - also werden alle Daten sukzessive händisch nachgepflegt.

Weiterhin findet eine Fusion mit dem GSR-Forum statt. Dazu laufen die Vorbereitungen im Hintergrund ebenfalls.

Eure Vorschläge und wünsche aus dem alten Beitrag sind alle bekannt und werden in den nächsten Stunden hier noch einmal ergänzt und dann abgearbeitet.


In diesem Sinne: Gut Ding will Weile und Nerven haben. :daumen:


PS: natürlich wird das Design angepasst! ;-)
 
Zuletzt bearbeitet:

Kommentare

Ich komme zwar bis dahin wo man mit zwei Fingern verschieben kann, aber die Karte an sich ist nicht sichtbar, lädt nicht.
Benutze nur Smartphone
 
Dazu kann ich dir nichts sagen. Aber ich bin so dreist anzunehmen, dass es dann möglicherweise an deinem mobilen Browser oder OS liegt.

Das Video da oben ist übrigens deshalb so rucklig, weil ich ein Zubehördisplay verbaut habe, welches der letzte Rotz ist.
Auf dem iPad funktioniert es tadellos und dem iPhone XS meiner Frau auch.

Da es sich um die google-Karte handelt, gehe ich auch eigentlich davon aus, dass alle Android-Systeme da keine Probleme haben werden.
Von anderen MobileOS habe ich leider keine Ahnung.
 
Ich hab den "Fehler" gefunden.

Zum 1.: Es mussten mindestens vier Buchstaben sein. Sonst sprang die Suche nicht an. Das hab ich jetzt auf drei Buchstaben reduziert.
Zum 2.: USB findet er so immer noch nicht.

USB hingegen schon. USB wurde in zusammenhängenden Begriffen genutzt.

11804


Das stellt mich nicht allzu glücklich.

Es gibt da noch das "Enhanced Search" AddOn von Xenforo.

XenForo Erweiterte Suche - $55

XenForo Enhanced Search wurde entwickelt, um Ihren Benutzern eine deutlich bessere Suchleistung und zusätzliche Suchoptionen zu bieten. Es ist gebaut, um die Vorteile von Elasticsearch zu nutzen, das auf Lucene aufgebaut ist. Dies führt zu einer hervorragenden Leistung, selbst bei Millionen von Inhalten. Elasticsearch ermöglicht eine nahezu unbegrenzte Skalierbarkeit und Redundanz, da die Suche auf mehreren Servern durchgeführt werden kann. Darüber hinaus profitieren Sie von einer sehr kleinen Stoppwortliste und keiner Mindestwortlänge, so dass fast jede Suche aussagekräftige Ergebnisse liefert. Elasticsearch bietet auch Unterstützung bei der Rückgabe von Ergebnissen, je nachdem, wie relevant sie für Ihre Suche sind. Sie können die Relevanzordnung auf der Seite der erweiterten Suche auswählen.
Eventuell muss ich das dazu kaufen, wenn sich mangelhafte Suchergebnisse häufen. Wobei die Suche hier als AddOn sich so ließt, als würden wir damit mit Kanonen auf Spatzen schießen ... :xxbazooka:


---------------------------

Nachtrag:

Wenn man auf "Erweiterte Suche" geht und dann innerhalb der Themen sucht, wird man mit dem Suchbegriff USB ohne * auch über 10 Seiten zugeworfen.
Aber das das nicht oben in der einfachen Suchfunktion klappt, irritiert mich gelinde gesagt. Das mag ich nicht. Ich mag es einfach.


11805


11806
 
Zuletzt bearbeitet:
Ich bin drauf gekommen, weil ein neues Mitglied nach sowas gesucht hat, die Sufu aber nur den Fehler ausgehustet hat.

Dank dir.
 
Transparenz-Update #1

Ich muss einmal deutlich festhalten, dass nicht alles aus des Meisters Hand... Hand und Fuß hatte. So hat zum Beispiel der strukturelle Aufbau auf dem Server durch Charly arg gelitten.

Ich habe heute versucht, die vor einem Tag aktualisierte Version des Chats einzuspielen.

Diese hat erneut nur zu Fehlern geführt - innerhalb von Sekunden wurde das ServerLOG zugeschossen.
Ich gehe also von einem vor langer Zeit hausgemachten Problem aus.. und werde in der Konsequenz im Keller mal gewaltig aufräumen müssen.
 
Na ja, ich kann jetzt nicht behaupten, dass ich den Chat vermissen würde. Ich sehe ihn als sehr unbedeutend für die Community. Er wurde nie wirklich genutzt. Ist ein Gimmick, mehr nicht.
 
Howdy allerseits,

wie ihr sehen könnt, habe ich die KnowledgeBase wieder zurück gebracht.

Die Einträge der alten KB sind annähernd 1:1 übernommen worden. Einige Einträge habe ich aber rausgelassen, da ich mir sehr sicher war, dass diese nicht originär durch BT012SS geschrieben wurden - und auch die nachträgliche Nennung der Quelle umfasst nicht die 1:1 Kopie im Sinne des Zitatrechts :boing:

Entsprechend: fühlt euch eingeladen, selbst interessante Artikel für die KB zu finden, von welcher alle anderen ebenfalls profitieren.


Als nächstes steht die Galerie in den Startlöchern und ist im Hintergrund vorbereitet worden.
Deshalb werden wir in den nächsten Stunden noch einmal die ein oder andere Auszeit haben.



PS: Die Übernahme der Daten erfolgte händisch - also ich habe jeden Einzelnen Beitrag neu geschrieben und editiert, also Bilder runtergeladen, hier neu hochgeladen und in die Einträge eingebunden und nach Fertigstellung dann den Verfasser geändert - auf euch, die ihr die Beiträge geschrieben habt. Dabei können! Fehler passiert sein (war auch heute Nacht zwischen 1- und 4 Uhr..). Wenn ihr diese seht, könnt ihr diese selbstständig jederzeit wieder korrigieren!
 
Zuletzt bearbeitet:
Ich habe jetzt in den letzten Wochen ca. 10 Mal die Galerie importiert - die Ursprüngliche aus dem "alten" Forum, welche ihr mit dutzenden Alben und tausenden Bildern gefüllt habt.

Der Import funktioniert soweit, als dass Bilder und Alben importiert werden und darstellbar sind.

ABER: Die Alben werden nicht euren Nutzerprofilen zugewiesen, sondern der User nur benannt. Entsprechend könnt ihr eure eigenen Bilder/Alben nicht editieren.

Nachdem ich jetzt zweifelsfrei festgestellt habe, dass es sich dabei um einen Bug handelt, ist der Support dran und ich bleibe am Ball.

So sollte es sein...
Bildschirmfoto 2019-03-22 um 14.37.02.png


So sieht es aktuell aus.
Bildschirmfoto 2019-03-22 um 14.36.50.png
 
Zuletzt bearbeitet:
PS: Die Übernahme der Daten erfolgte händisch - also ich habe jeden Einzelnen Beitrag neu geschrieben und editiert, also Bilder runtergeladen, hier neu hochgeladen und in die Einträge eingebunden und nach Fertigstellung dann den Verfasser geändert - auf euch, die ihr die Beiträge geschrieben habt.
Hut ab!!:hi::thank-you2:
 
Oben